NexusLite and Java 7 Update 51 Security

When working with our NexusLite product, make sure you have the latest firmware installed.  You can check in the downloads section to see the current released version. If you open the NexusLite control panel via your web browser and are prompted with a security...

Java incompatibility issue with Web Enrollment

Issue: There is a minor issue with image displaying/loading in Web Enrollment for AmanoNet and Nexus220 if you have Java v1.6.0 u26 or later is installed. Resolution: While there currently is no solution to this issue, we are working quickly to resolve for current and...